Özel istemci ve sunucu tarafı oluşturmak için kullanılabilecek düşük seviye HTTP taşıma bileşenleri seti Apache HttpComponents Core‘nin 5.5-beta4 sürümü duyuruldu. Minimum ayak izi ile istemci ve sunucu tarafı HTTP hizmetleri sunan Apache HttpComponents Core; klasik Java I/O ve engellenmeyen, etkinlik odaklı I/O’ya dayanan I/O modelini engelleme Java NIO’ya dayanan model olmak üzere iki I/O’yu destekliyor. Java NIO’ya dayalı asenkron infaz desteği de dahil olmak üzere HTTP taşıma kütüphanesi içeren yazılım, HTTP için kapsamlı öncelikleme şemasıyla geliyor. Bu BETA sürümün, HTTP/2 protokolü uyumluluğunda birden fazla iyileştirme ve performans optimizasyonu içeridiği, Digest Fields (RFC 9530) desteği sunduğu ve asenkron IO oturum havuzu işlevselliğini geliştirdiği söyleniyor. Bunun, 5.5 GA sürümünden önceki son BETA sürümü olması bekleniyor. Bu sürüm, kararlı 5.4 dalındaki tüm düzeltmeleri içerdiği belirtilirken, bağlantı havuzu uygulamasında iyileştirmeler yapıldığı ifade ediliyor. HTTP mesaj akışı API’leri ve HTTP/2 mesaj akışı zaman aşımı desteği eklendiği belirtilirken, bağlantı başına bekleyen HTTP/2 istek komutları sınırlandırılmış bulunuyor. RFC 7540, HPACK (RFC 7541) ve HTTP/2 (RFC 9113) ile uyumluluk iyileştirilmiş bulunuyor. Apache HttpComponents Core 5.5-beta4 hakkında bilgi edinmek için sürüm duyurusu incelenebilir.
Tag Archives | istemci
Apache HttpComponents Client 5.6.5 duyuruldu
Özel istemci ve sunucu tarafı oluşturmak için kullanılabilecek düşük seviye HTTP taşıma bileşenleri seti Apache HttpComponents Core‘nin 5.6.5 sürümü duyuruldu. Minimum ayak izi ile istemci ve sunucu tarafı HTTP hizmetleri sunan Apache HttpComponents Core; klasik Java I/O ve engellenmeyen, etkinlik odaklı I/O’ya dayanan I/O modelini engelleme Java NIO’ya dayanan model olmak üzere iki I/O’yu destekliyor. Java NIO’ya dayalı asenkron infaz desteği de dahil olmak üzere HTTP taşıma kütüphanesi içeren yazılım, HTTP için kapsamlı öncelikleme şemasıyla geliyor. Bunun bir bakım sürümü olduğu, önceki sürümden bu yana bulunan çeşitli hataları düzelttiği belirtilirken, bunlar arasında, mesaj alışverişinin süresiz olarak takılı kalmasına neden olabilen asenkron Brotli sıkıştırma açma kodundaki hatanın da bulunduğu söyleniyor. HttpCore 5.4.4 sürümüne yükseltilirken, eş zamanlı HTTP/2 istek gövdesi tekrar oynatımının önlendiği söyleniyor. Büyük giriş tamponlarıyla Brotli sıkıştırma açma işleminde yaşanan takılma düzeltilmiş bulunuyor. Apache HttpComponents Core 5.6.5 hakkında bilgi edinmek için sürüm duyurusu incelenebilir.
Apache HttpComponents Core 5.6.5 edinmek için aşağıdaki linklerden yararlanabilirsiniz.
Apache HttpComponents Core 5.4.4 duyuruldu
Özel istemci ve sunucu tarafı oluşturmak için kullanılabilecek düşük seviye HTTP taşıma bileşenleri seti Apache HttpComponents Core‘nin 5.4.4 sürümü duyuruldu. Minimum ayak izi ile istemci ve sunucu tarafı HTTP hizmetleri sunan Apache HttpComponents Core; klasik Java I/O ve engellenmeyen, etkinlik odaklı I/O’ya dayanan I/O modelini engelleme Java NIO’ya dayanan model olmak üzere iki I/O’yu destekliyor. Java NIO’ya dayalı asenkron infaz desteği de dahil olmak üzere HTTP taşıma kütüphanesi içeren yazılım, HTTP için kapsamlı öncelikleme şemasıyla geliyor. Yeni sürümün bir bakım sürümü olduğu ve HTTP/1.1 mesaj arabellek yapılandırmasını optimize ettiği belirtilirken, kesintiye uğramış yazma işlemlerinden sonra eşzamansız varlık üretici durum sıfırlamalarının işlenmesinin düzeltildiği söyleniyor. HttpException mesajlarındaki kontrol karakterlerinin onaltılık kodlaması da düzeltilirken, URIBuilder kodlama politikası dokümantasyonu ve null sıfırlama davranışı düzeltilmiş bulunuyor. Varsayılan HTTP/1.1 arabellek boyutunun 32 KiB’ye çıkarıldığı söyleniyor. Apache HttpComponents Core 5.4.4 hakkında bilgi edinmek için sürüm duyurusu incelenebilir.
Apache MINA SSHD 2.20.0 ve 3.0.0-M6 duyuruldu
Hem istemci hem de sunucu tarafında SSH protokollerini desteklemek için %100 saf Java kütüphanesi olan Apache MINA SSHD‘nin 2.20.0 ve 3.0.0-M6 sürümleri duyuruldu. Unix işletim sistemlerindeki SSH istemcisi veya SSH sunucusunun yerini almayı hedeflemeyen, bunun yerine SSH desteği gerektiren Java tabanlı uygulamalar için destek sağlayan Apache MINA SSHD; çeşitli G/Ç arka uçlarından yararlanabilen Java kütüphanesidir. Java’nın AsynchronousSocketChannels’ını kullanan ve varsayılan taşıma yöntemi yerleşik olan yazılım haricinde Netty asenkron olay odaklı ağ çerçevesi de destekleniyor. Güvenlik düzeltmeleriyle gelen yeni sürümler, 2.20.0 sürümü için yalnızca parola ve klavye etkileşimli kimlik doğrulama şemaları için eşzamansız kimlik doğrulamasına izin verildiği söyleniyor. LDAP kimlik doğrulamasını (sshd-ldap) iyileştiren yeni sürüm, açık anahtar kimlik doğrulamasında (sunucu tarafı) authorized_keys işlemesinde “from” ve “expiry-time” seçeneklerinin uygulanmasının söz konusu olduğu söyleniyor. 3.0.0-M6 için bu altıncı kilometre taşının KexOutputHandler’ın kendi kendine kilitlenmesinin düzeltilmesiyle geldiği ifade ediliyor. Yeni sürüm ayrıca proxy’den gelen parçalı yanıtları işleme özelliği kazanmış bulunuyor. Apache MINA SSHD 2.20.0 ve 3.0.0-M6 hakkında bilgi edinmek için GitHub sürümler sayfasını ve Apache MINA SSHD 2.20.0 sürüm notlarını ve 3.0.0-M6 için değişiklik günlüğünü inceleyebilirsiniz.
Apache MINA SSHD 2.20.0 ve 3.0.0-M6 edinmek için aşağıdaki linklerden yararlanabilirsiniz.
Less 710 duyuruldu
CSS formatına derlenebilen açık kaynak kodlu dinamik bir biçim dili olan Less’in 710 sürümü duyuruldu. Komutlarda ve || komutlarda, ^N işaret mektubu yerine hat numarasının girmesine izin veririldiği belirtilirken, OSC 8 bağlantılarının özel renklendirilmesi için -DO eklendiği ifade ediliyor. Mesajların diğer dillere çevrilmesine izin veren LESSMSG eklendiği belirtilirken, uçucu geri dönüş değerleri ile sistemdeki sorunların düzeltildiği söyleniyor. Kötü biçimlendirilmiş ikili daha az anahtar dosyası için hata işlemenin iyileştirildiği belirtilirken, eskimiş daha az anahtar programının çıkarıldığı söyleniyor. & filtrelenmiş çıktının sonunda eksik “END” mesajının düzeltildiği belirtilirken, bir durum mesajı ASCII olmayan avcılar içerdiğinde veya çok dar bir ekranda görüntülendiğinde ekran hatalarının düzeltildiği söyleniyor. ASS’tan esinlenerek Alexis Sellier tarafından tasarlanan Less; sunucu veya istemci tarafından çalıştırılabiliyor. LESS’in diğer CSS ön-derleyicilerinden farkı LESS’in tarayıcı tarafında çalışan less.js ile gerçek zamanlı derleme imkanı sunmasıdır. Apache 2 lisansı ile kullanıma sunulan Less’in yeni sürümü 710 hakkında bilgi edinmek için sürüm notlarını inceleyebilirsiniz.
libgnunetchat 0.8.0 duyuruldu
GNUnet projesinin bir parçası olan libgnunetchat‘in 0.8.0 sürümü kullanımda. Özgür bir yazılım olan GNUnet‘in bir parçası olan yazılımın, GNU Affero Genel Kamu lisansı koşulları altında kullanıma sunulduğu belirtilirken, bu kütüphanenin, tipik bir mesajlaşma uygulamasının işlevselliğini sağlamak için farklı GNUnet servislerinden istemci API’sini kullanan bir soyutlama katmanı olarak geldiği hatırlatılıyor. libgnunetchat 0.8.0’ın yayınlandığını duyurmaktan mutluluk duyulduğu belirtilirken, bu kitaplığın, tipik bir mesajlaşma uygulamasının işlevselliğini sağlamak için farklı GNUnet hizmetlerinden istemci API‘sini kullanan bir soyutlama katmanı getirdiği ifade ediliyor. Bunun, en son GNUnet sürümü 0.28.0‘daki büyük değişikliklerle uyumluluk sağlayan küçük bir yeni sürüm olduğu belirtilirken, API’deki bazı küçük sorunların giderildiği, ek olarak, kütüphane daha yeni PILS hizmetini kullanacak şekilde güncellenirken, paylaşılan dosyalar için ek şifreleme katmanının kaldırıldığı ifade ediliyor. Gelecekte genel karmaşıklığı azaltmak için GNUnet’teki FS hizmetinin şifreleme katmanına güvenilmesinin amaçlandığı belirtiliyor. libgnunetchat kullanan uygulamaların eski sürümleri bu sürümle uyumlu kalmaya devam ettiği söyleniyor. libgnunetchat 0.8.0 hakkında bilgi edinmek için sürüm duyurusunu ya da GitLab sayfasını inceleyebilirsiniz. Continue Reading →
libgnunetchat 0.8.0 edinmek için aşağıdaki linklerden yararlanabilirsiniz.
Tor 0.4.8 serisi ömrünün sonuna (EOL) geldi
İnternet üzerinde kişisel bilgileri gizleyebilme ve anonim olma olanağı sağlayan ünlü güvenlik aracı Tor‘un 0.4.8 serisi ömrünün sonuna (EOL) geldi. Bilindiği gibi, Tor Projesi içindeki farklı ekipler, yakın gelecekte ağın Rust tabanlı Tor uygulamasına doğru yükseltilmesine başlanılması umulan Arti Relay projesi üzerinde çalışıyor. Bu çalışmayı desteklemek için, 0.4.8 ve daha önceki C Tor sürümleriyle uyumluluğun yakında aktif olarak durdurulacağının planlandığı duyurulmak isteniyor. Bu, bu sürümlerin, hedef tarih olan 1 Eylül 2026’dan sonra ağda artık hiç çalışmayacağı anlamına geliyor. Tor Browser’in güncel bir sürümünü kullanan Tor Browser kullanıcıları, bundan etkilenmeyecek. Ancak daha eski, belki de çok iyi bakımı yapılmayan bir Onion Service kullananlar veya C Tor’u entegre eden bir uygulama geliştirenler; Tor 0.4.8 serisinin, 1 Haziran’da kullanım ömrünün sonuna ulaştığını ve bu sürüm serisine artık güncelleme gelmeyeceğini bilmek durumundalar. Bu nedenle, kullanıcıların, Tor 0.4.9 serisine (veya daha yenisine) yükseltme yapmaları şiddetle öneriliyor.

Hem istemci hem de röle tarafında Arti’ye yönelik çalışmalarla birlikte, ağ ekibinin Tor ekosisteminden kaldırılmak istenen birkaç özelliği belirlediği belirtilirken, bunu sağlamak için 0.4.8 serisinin çalışmayı durduracağı tarihin hızlandırması gerektiği ifade ediliyor. Sonuç olarak Tor kullanıcılarını yazılımın 0.4.9 serisine (veya daha yenisine) yükseltmeleri gerektiğini hatırlatıyoruz. Tor 0.4.8 serisinin ömrünün sonuna (EOL) geldiğine ilişkin duyuruya buradan ulaşabilirsiniz.
