Tag Archives | sunucu

Apache HttpComponents Core 5.5-beta4 duyuruldu

Özel istemci ve sunucu tarafı oluşturmak için kullanılabilecek düşük seviye HTTP taşıma bileşenleri seti Apache HttpComponents Core‘nin 5.5-beta4 sürümü duyuruldu. Minimum ayak izi ile istemci ve sunucu tarafı HTTP hizmetleri sunan Apache HttpComponents Core; klasik Java I/O ve engellenmeyen, etkinlik odaklı I/O’ya dayanan I/O modelini engelleme Java NIO’ya dayanan model olmak üzere iki I/O’yu destekliyor. Java NIO’ya dayalı asenkron infaz desteği de dahil olmak üzere HTTP taşıma kütüphanesi içeren yazılım, HTTP için kapsamlı öncelikleme şemasıyla geliyor. Bu BETA sürümün, HTTP/2 protokolü uyumluluğunda birden fazla iyileştirme ve performans optimizasyonu içeridiği, Digest Fields (RFC 9530) desteği sunduğu ve asenkron IO oturum havuzu işlevselliğini geliştirdiği söyleniyor. Bunun, 5.5 GA sürümünden önceki son BETA sürümü olması bekleniyor. Bu sürüm, kararlı 5.4 dalındaki tüm düzeltmeleri içerdiği belirtilirken, bağlantı havuzu uygulamasında iyileştirmeler yapıldığı ifade ediliyor. HTTP mesaj akışı API’leri ve HTTP/2 mesaj akışı zaman aşımı desteği eklendiği belirtilirken, bağlantı başına bekleyen HTTP/2 istek komutları sınırlandırılmış bulunuyor. RFC 7540, HPACK (RFC 7541) ve HTTP/2 (RFC 9113) ile uyumluluk iyileştirilmiş bulunuyor. Apache HttpComponents Core 5.5-beta4 hakkında bilgi edinmek için sürüm duyurusu incelenebilir. 

Continue Reading →

 

 

Apache HttpComponents Core 5.5-beta4 edinmek için aşağıdaki linklerden yararlanabilirsiniz.

Apache HttpComponents Client 5.6.5 duyuruldu

Özel istemci ve sunucu tarafı oluşturmak için kullanılabilecek düşük seviye HTTP taşıma bileşenleri seti Apache HttpComponents Core‘nin 5.6.5 sürümü duyuruldu. Minimum ayak izi ile istemci ve sunucu tarafı HTTP hizmetleri sunan Apache HttpComponents Core; klasik Java I/O ve engellenmeyen, etkinlik odaklı I/O’ya dayanan I/O modelini engelleme Java NIO’ya dayanan model olmak üzere iki I/O’yu destekliyor. Java NIO’ya dayalı asenkron infaz desteği de dahil olmak üzere HTTP taşıma kütüphanesi içeren yazılım, HTTP için kapsamlı öncelikleme şemasıyla geliyor. Bunun bir bakım sürümü olduğu, önceki sürümden bu yana bulunan çeşitli hataları düzelttiği belirtilirken, bunlar arasında, mesaj alışverişinin süresiz olarak takılı kalmasına neden olabilen asenkron Brotli sıkıştırma açma kodundaki hatanın da bulunduğu söyleniyor. HttpCore 5.4.4 sürümüne yükseltilirken, eş zamanlı HTTP/2 istek gövdesi tekrar oynatımının önlendiği söyleniyor. Büyük giriş tamponlarıyla Brotli sıkıştırma açma işleminde yaşanan takılma düzeltilmiş bulunuyor. Apache HttpComponents Core 5.6.5 hakkında bilgi edinmek için sürüm duyurusu incelenebilir. 

Continue Reading →

 

 

Apache HttpComponents Core 5.6.5 edinmek için aşağıdaki linklerden yararlanabilirsiniz.

Apache HttpComponents Core 5.4.4 duyuruldu

Özel istemci ve sunucu tarafı oluşturmak için kullanılabilecek düşük seviye HTTP taşıma bileşenleri seti Apache HttpComponents Core‘nin 5.4.4 sürümü duyuruldu. Minimum ayak izi ile istemci ve sunucu tarafı HTTP hizmetleri sunan Apache HttpComponents Core; klasik Java I/O ve engellenmeyen, etkinlik odaklı I/O’ya dayanan I/O modelini engelleme Java NIO’ya dayanan model olmak üzere iki I/O’yu destekliyor. Java NIO’ya dayalı asenkron infaz desteği de dahil olmak üzere HTTP taşıma kütüphanesi içeren yazılım, HTTP için kapsamlı öncelikleme şemasıyla geliyor. Yeni sürümün bir bakım sürümü olduğu ve HTTP/1.1 mesaj arabellek yapılandırmasını optimize ettiği belirtilirken, kesintiye uğramış yazma işlemlerinden sonra eşzamansız varlık üretici durum sıfırlamalarının işlenmesinin düzeltildiği söyleniyor. HttpException mesajlarındaki kontrol karakterlerinin onaltılık kodlaması da düzeltilirken, URIBuilder kodlama politikası dokümantasyonu ve null sıfırlama davranışı düzeltilmiş bulunuyor. Varsayılan HTTP/1.1 arabellek boyutunun 32 KiB’ye çıkarıldığı söyleniyor. Apache HttpComponents Core 5.4.4 hakkında bilgi edinmek için sürüm duyurusu incelenebilir. 

Continue Reading →

 

 

Apache HttpComponents Core 5.4.4 edinmek için aşağıdaki linklerden yararlanabilirsiniz.

StartOS 0.4.0.2 duyuruldu

Kişisel sunucular için optimize edilmiş, Debian tabanlı, Amerikan kökenli bir GNU/Linux dağıtımı olan StartOS‘un 0.4.0.2 sürümü, Aiden McClelland tarafından duyuruldu. Kendi kendine barındırılan yazılım hizmetlerinin keşfini, kurulumunu, ağ yapılandırmasını, hizmet yapılandırmasını, veri yedeklemesini, bağımlılık yönetimini ve sağlık izlemesini kolaylaştıran sistem; kurulumdan sonra çeşitli hizmetlerin önceden yüklenmiş olduğu bir Firefox tarayıcısında önyüklenir ve projenin çevrimiçi pazarından erişilebilen çeşitli Bitcoin, iletişim, veri ve yapay zeka hizmetleri de dahil olmak üzere birçok hizmeti sunar. Sunucuya yerel olarak veya Tor ağının Onion hizmeti aracılığıyla dünyanın herhangi bir yerinden erişilebiliyor. Start9 Labs. Inc. tarafından geliştirilen sistemin yeni sürümünün, düz metin adresleri için güvenilir ağ anahtarı, hizmetler için donanım sanallaştırması ve uzun bir ağ, yedekleme ve arayüz düzeltmeleri listesi eklediği söyleniyor. NVIDIA kalıplarının artık NVIDIA’nın açık kaynaklı çekirdek modüllerini kullandığı ifade ediliyor. StartOS 0.4.0.2 hakkında bilgi edinmek için GitHub sürümler sayfasını inceleyebilirsiniz. 

Continue Reading →

 

 

StartOS 0.4.0.2 edinmek için aşağıdaki linkten yararlanabilirsiniz. 

Less 710 duyuruldu

CSS formatına derlenebilen açık kaynak kodlu dinamik bir biçim dili olan Less’in 710 sürümü duyuruldu. Komutlarda ve || komutlarda, ^N işaret mektubu yerine hat numarasının girmesine izin veririldiği belirtilirken, OSC 8 bağlantılarının özel renklendirilmesi için -DO eklendiği ifade ediliyor. Mesajların diğer dillere çevrilmesine izin veren LESSMSG eklendiği belirtilirken, uçucu geri dönüş değerleri ile sistemdeki sorunların düzeltildiği söyleniyor. Kötü biçimlendirilmiş ikili daha az anahtar dosyası için hata işlemenin iyileştirildiği belirtilirken, eskimiş daha az anahtar programının çıkarıldığı söyleniyor. & filtrelenmiş çıktının sonunda eksik “END” mesajının düzeltildiği belirtilirken, bir durum mesajı ASCII olmayan avcılar içerdiğinde veya çok dar bir ekranda görüntülendiğinde ekran hatalarının düzeltildiği söyleniyor. ASS’tan esinlenerek Alexis Sellier tarafından tasarlanan Less; sunucu veya istemci tarafından çalıştırılabiliyor. LESS’in diğer CSS ön-derleyicilerinden farkı LESS’in tarayıcı tarafında çalışan less.js ile gerçek zamanlı derleme imkanı sunmasıdır. Apache 2 lisansı ile kullanıma sunulan Less’in yeni sürümü 710 hakkında bilgi edinmek için sürüm notlarını inceleyebilirsiniz.

Continue Reading →

 

 

 

 

Less 710 edinmek için aşağıdaki linkten yararlanabileceksiniz.

CapivaraOS 1.2.4 çıktı

Fedora tabanlı Brezilya kökenli bir masaüstü ve sunucu GNU/Linux dağıtımı olan CapivaraOS‘nin 1.2.4 sürümü çıktı. “Marsh” (KDE Plasma), “Snout” (GNOME) ve “Pup” (Xfce) olmak üzere üç masaüstü sürümünün yanı sıra “HERD” adlı ayrı bir ev sunucusu sürümü de bulunan sistemin tüm sürümleri Brezilya Portekizcesine yerelleştirilmiş bulunuyor. Anaconda sistem yükleyicisini kullanan ve birçok popüler web, üretkenlik ve multimedya uygulamasını içeren sistem, Fedora 44 üzerine kurulmuş bulunuyor. Fedora Projesi ile bağlantılı olmayan, bağımsız, topluluk odaklı bir proje CapivaraOS; Marsh sürümüyle KDE Plasma masaüstü ortamına sahip modern bir masaüstü deneyimini temel alıyor. CapivaraOS 1.2.4 hakkında bilgi edinmek için README.md sayfasını inceleyebilirsiniz.

Continue Reading →

 

 

CapivaraOS 1.2.4 edinmek için aşağıdaki linklerden yararlanabilirsiniz.

C-Kermit 11.0 duyuruldu

Metin tabanlı bir kullanıcı arayüzü, taşınabilir bir betik dili (kabuk ile benzer bir kavrama sahip, ancak expect gibi yerleşik ekran kazıma otomasyonu ve yerleşik dosya aktarımı ile), Kermit dosya aktarım protokolünün bir uygulaması, ağ istemcisi ve sunucusu, seri port arayüzü, BBS istemcisi ve daha fazlasını içeren C-Kermit 11.0, John Goerzen tarafından duyuruldu. 1981’de Columbia Üniversitesi‘nde Frank da Cruz ve Bill Catchings’in başlattıkları bir seri protokol olan Kermit’in 45 yıl sonra gelen yeni sürümü C-Kermit 11.0 duyuruldu. Kermit, 1970’lerin çoktan ölmüş bilgisayarlarından, 1990’ların cep hesap makinelerine ve modern masaüstü ve mobil işletim sistemlerine kadar yüzlerce platformda çalışıyordu. Open Kermit, bu süre zarfında Kermit projesini devam ettiren üçüncü proje oluyor. Kermit’in kurucularından birinin (Frank da Cruz) 44 yıl sonra emekli olmasının ardından, Open Kermit onu ileriye taşıyan son aşama oluyor. C-Kermit 11.0’ın 2011’deki son 9.0.302’den bu yana ilk beta olmayan önemli bir yeni sürüm olduğunu belirten Goerzen; bunun, C-Kermit kod tabanını modernize etmek ve geliştirmek için önemli bir çabayı temsil ettiğini söyledi. Farklı Kermit sürümleri arasındaki ilişki hakkında daha fazla bilgi için geçmiş ve SSS sayfalarına bakılabileceği belirtiliyor. C-Kermit 11.0 hakkında bilgi edinmek için GitHub sürümler sayfasını ya da değişiklik sayfasını inceleyebilirsiniz.

Continue Reading →

 

 

C-Kermit’in TCP yığınının artık IPv6’yı desteklediği ve IPv6 bağlantısı olmayan veya sistem kütüphaneleri IPv6’yı desteklemeyen ana bilgisayarlarda sorunsuz bir şekilde IPv4’e geçiş yaptığı belirtilirken, NDK derlemeleri ve özel bir herald dahil olmak üzere Android platform desteği sağlanmış bulunuyor. Standart dizin ve dokunmatik dosya seçme anahtarlarını kullanarak dosyalarda dizeleri aramak ve değiştirmek için yeni bir CHANGE komutu oluşturulduğu söyleniyor. C-Kermit 11.0 edinmek için aşağıdaki linkten yararlanabilirsiniz.