Archive | Programlama

Apache Johnzon 1.3.1 çıktı

Apache Yazılım Vakfı (Apache Software Foundation – ASF) tarafından geliştirilen ve Java ile JSON verilerini işlemeyi sağlayan açık kaynaklı bir proje olan Apache Johnzon‘un 1.3.1 sürümü çıktı. JSON-P (Java API for JSON Processing) JSR-353 / JSON-P 2.1 spesifikasyonunu tam olarak uygulayan yazılım, JSON-B 3.0 spesifikasyonunu tam olarak destekliyor. esneleri doğrudan JSON formatına veya JSON verilerini Java nesnelerine (Bean) dönüştüren johnzon-mapper modülüne sahip yazılım, RESTful web servisleri için JAX-RS entegrasyonu sunuyor (johnzon-jaxrs). Ayrıca, WebSocket mesajlarını JSON-P veya Mapper ile kodlayıp çözmek için johnzon-websocket modülünü barındırıyor. JSON-P standartlarını uygulayan çekirdek modül johnzon-core, Java nesnelerini JSON’a eşlemek (mapping) için kullanılan johnzon-mapper, Apache TomEE gibi uygulama sunucularında JAX-RS sağlayıcısı olarak görev yapan johnzon-jaxrs başlıca modüllerini oluşturuyor.

Continue Reading →

 

Apache Johnzon 1.3.1 edinmek için aşağıdaki linklerden yararlanabilirsiniz.

Apache SeaTunnel 3.0.0 duyuruldu

Büyük ölçekli ve farklı kaynaklardaki verileri yüksek performansla entegre etmek, dönüştürmek ve senkronize etmek için geliştirilmiş, açık kaynaklı, dağıtık ve çok modüllü bir veri entegrasyonu (ETL / ELT) platformu olan Apache SeaTunnel‘in 3.0.0 sürümü duyuruldu. 200’den fazla yerleşik bağlayıcıya sahip olan yazılım; MySQL, PostgreSQL vb. veritabanları, Apache Kafka, Apache Pulsar vb. akış platformları, Amazon S3, HDFS, Apache Iceberg, Apache Paimon vb. depolama ve Lakehouse gibi araçlarla birlikte çalışıyor. Veri işleme ve çalıştırma motoru olarak kendi yerel motoru olan SeaTunnel Zeta’nın yanı sıra Apache Flink ve Apache Spark ile entegre çalışabilen yazılım, hem toplu (batch) veri işleme hem de gerçek zamanlı (real-time streaming) ve değişiklik yakalama (CDC – Change Data Capture) senaryolarını destekliyor. Yeni sürüm, 2.3.13’ten bu yana 927 commit, 30 yeni eklenen bağlantı noktası, 107 değiştirilen bağlantı noktası içeriyor. Apache SeaTunnel 3.0.0 hakkında bilgi edinmek için sürüm notlarını inceleyebilirsiniz.

Continue Reading →

 

Apache SeaTunnel 3.0.0 edinmek için aşağıdaki linkten yararlanabilirsiniz.

Ruby 4.0.9 duyuruldu

Ruby programlama dilinin 4.0.9 sürümü duyuruldu. Ruby 4.0.9’u duyurmaktan mutluluk duyulduğu belirtiliyor. makenowjust tarafından büyük düzenli ifadelerde taşan tekrarlanan/null kontrolü yapılan kimliklerin reddedildiği belirtilirken, pipe2() ve dup3() kullanılamaması nediyle, macOS 27 SDK ile macOS 26’da derlemenin çökmesi hatası düzeltilmiş bulunuyor. RubyVM::ZJIT.reset_stats! ZJIT etkinleştirilmediğinde işlemi sonlandırdığı belirtilirken, array’in zip fonksiyonu tarafından tetiklenen heap buffer overflow hatasının düzeltildiği söyleniyor. Bilgi için tam değişiklik günlüğünün incelenebileceği belirtiliyor. Nesne yönelimli bir programlama dili olan Ruby; Unix türevleri dışında Windows, Mac OS X, BeOS, Amiga, OS/2, Symbian gibi hemen hemen tüm platformlarda çalışabilen; GPL ile lisanslanmış, özgür bir yazılımdır. WASI (WebAssembly Sistem Arayüzü), bu tür kullanım durumları için tasarlanmıştır. Bu tür uygulamaların işletim sistemleri ile iletişim kurması gerekse de WebAssembly, sistem arabirimi olmayan bir sanal makinede de çalışır. Ruby 4.0.9 hakkında bilgi edinmek için GitHub sayfasını inceleyebilirsiniz.

Continue Reading →

 

 

Ruby 4.0.9 edinmek için aşağıdaki linkten yararlanabilirsiniz. 

Apache SIS™ 1.7 duyuruldu

Apache Mekansal Bilgi Sistemi (SIS), jeo-uzamsal uygulamalar geliştirmek için ücretsiz bir yazılım olan Java dil kütüphanesidir. SIS, coğrafi özellikler ve ilişkili meta veriler için veri yapıları ve bu veri yapılarını manipüle etmek için yöntemler sağlar. Kütüphane, GeoAPI 3.0.2 arayüzlerinin bir uygulamasıdır ve masaüstü veya sunucu uygulamaları için kullanılabilir. Kütüphane Apache 2 lisansı altında kullanılmaktadır. Apache SIS™‘in 1.7 sürümü duyuruldu. Apache Derby’nin kullanımının sona ermesinin ardından, bu sürüm org.apache.sis.referencing.database modülünü (HSQLDB’ye taşıdığı söyleniyor. sis-embedded-data, “sun.misc.Unsafe’de kalıcı olarak kullanımdan kaldırılmış bir yöntem çağrıldı” uyarısına neden olabiliyor. Geçici bir çözüm olarak, sis-embedded-data veritabanını geçici bir dizine açıyor, ancak bu geçici çözüm tüm ortamlarda geçerli olmayabiliyor. Bazı komut satırı örnekleri, sıralama sorunu nedeniyle geçici olarak bozulmuş olabiliyor. Kendi veritabanlarına bağlı uygulamalar, mevcut veritabanı motorlarından yararlanmak ve yukarıdaki sorunlardan kaçınmak için bunun yerine org.apache.sis.referencing.epsg modülünü (Maven yapıtı: sis-epsg) kullanmak gerekiyor. Bu sürüm bazı güvenlik açıklarını düzeltiyor. Apache SIS başka bir dosyayı açtığında, onu GML, GeoTIFF, NADCON veya NTv2 formatında ayrıştırmaya çalışıyor ve ilk hatada başarısız oluyor. Bu nedenle, bu güvenlik açıklarının hassas bilgilerin sızmasına neden olmasının olası olmadığı söyleniyor. Apache SIS’in güvenlik açısından hassas bir bağlamda nasıl kullanılacağına ilişkin öneriler için güvenlik politikasına bakılabileceği söyleniyor. sis-embedded-data kullanılırken NoClassDefFoundError: org/apache/derby/iapi/jdbc/EmbeddedDataSourceInterface hatasının düzeltildiği söyleniyor. Apache SIS™ 1.7 hakkında bilgi edinmek için sürüm notlarını inceleyebilirsiniz.

Continue Reading →

 

 

Apache SIS™ 1.7 edinmek için aşağıdaki linkten yararlanabilirsiniz.

Apache HttpComponents Core 5.5-beta4 duyuruldu

Özel istemci ve sunucu tarafı oluşturmak için kullanılabilecek düşük seviye HTTP taşıma bileşenleri seti Apache HttpComponents Core‘nin 5.5-beta4 sürümü duyuruldu. Minimum ayak izi ile istemci ve sunucu tarafı HTTP hizmetleri sunan Apache HttpComponents Core; klasik Java I/O ve engellenmeyen, etkinlik odaklı I/O’ya dayanan I/O modelini engelleme Java NIO’ya dayanan model olmak üzere iki I/O’yu destekliyor. Java NIO’ya dayalı asenkron infaz desteği de dahil olmak üzere HTTP taşıma kütüphanesi içeren yazılım, HTTP için kapsamlı öncelikleme şemasıyla geliyor. Bu BETA sürümün, HTTP/2 protokolü uyumluluğunda birden fazla iyileştirme ve performans optimizasyonu içeridiği, Digest Fields (RFC 9530) desteği sunduğu ve asenkron IO oturum havuzu işlevselliğini geliştirdiği söyleniyor. Bunun, 5.5 GA sürümünden önceki son BETA sürümü olması bekleniyor. Bu sürüm, kararlı 5.4 dalındaki tüm düzeltmeleri içerdiği belirtilirken, bağlantı havuzu uygulamasında iyileştirmeler yapıldığı ifade ediliyor. HTTP mesaj akışı API’leri ve HTTP/2 mesaj akışı zaman aşımı desteği eklendiği belirtilirken, bağlantı başına bekleyen HTTP/2 istek komutları sınırlandırılmış bulunuyor. RFC 7540, HPACK (RFC 7541) ve HTTP/2 (RFC 9113) ile uyumluluk iyileştirilmiş bulunuyor. Apache HttpComponents Core 5.5-beta4 hakkında bilgi edinmek için sürüm duyurusu incelenebilir. 

Continue Reading →

 

 

Apache HttpComponents Core 5.5-beta4 edinmek için aşağıdaki linklerden yararlanabilirsiniz.

PHP 8.2.35 güvenlik düzeltmeleri ile duyuruldu

PHP’nin old stable sürümü 8.2.35 duyuruldu. Çeşitli hataları giderilen ve kimi güvenlik düzeltmeleri ve kimi iyileştirmeler içeren yeni sürüm hakkında bilgi edinmek için haberler veya yükseltme sayfalarını inceleyebilirsiniz. PHP, ilk olarak Rasmus Lerdorf tarafından, web üzerinden sayfasını ziyaret edenleri izlemek amacıyla bir dizi Perl betiği kullanılarak geliştirilmişti. Ancak insanlar bununla ilgilenmeye başlayınca, Lerdorf bir betik motoru oluşturmaya karar verdi. Ayrıca formlara da destek verdi ve böylece PHP/F1 biçimlenmiş oldu. Adı duyuldukça kimi geliştiricinin dikkatini çekti ve böylece bir API oluşturuldu: PHP3 meydana geldi. Ardından Zend motoruyla PHP4 geldi. Günümüzde PHP; bloglardan forumlara, portal sistemlerinden veri tabanlarına, sınıflardan fonksiyonlara her türlü işlevde kullanılıyor. Bilindiği gibi bugün “PHP 8.5.12 güvenlik düzeltmeleri ile duyuruldu” başlıklı bir haber yapmış ve bu haberde, önemli güvenlik düzeltmeleri yapıldığını söylemiştik. Aynı durum, PHP 8.2.35 için de geçerli. PHP projesi, 8.2 dalının 1 bileşeninde 1 hata düzeltmesi içeren PHP 8.2.35 sürümünü yayınladı. PHP projesi, 8.2 dalı için bir bakım güncellemesi olan PHP 8.2.35’i yayınladı. Bu sürüm, Core dahil olmak üzere 1 bileşende 1 hata düzeltmesi sunuyor ve dalı üretim kullanımı için güncel tutuyor. Bu bir güvenlik sürümüdür: CVE-2026-109618 ve CVE-2026-109619 açıklarını ele almaktadır. Etkilenen sistemlerin derhal yükseltme yapması öneriliyor. PHP 8.2.35 hakkında bilgi edinmek için sürüm duyurusunu ve değişiklikler sayfasını inceleyebilirsiniz.

Continue Reading →

 

   PHP 8.2.35 edinmek için aşağıdaki linkten yararlanabilirsiniz.

PHP 8.3.36 güvenlik düzeltmeleri ile duyuruldu

PHP’nin old stable sürümü 8.3.36 duyuruldu. Çeşitli hataları giderilen ve çeşitli önemli güvenlik düzeltmeleri ve kimi iyileştirmeler içeren yeni sürüm hakkında bilgi edinmek için haberler veya yükseltme sayfalarını inceleyebilirsiniz. PHP, ilk olarak Rasmus Lerdorf tarafından, web üzerinden sayfasını ziyaret edenleri izlemek amacıyla bir dizi Perl betiği kullanılarak geliştirilmişti. Ancak insanlar bununla ilgilenmeye başlayınca, Lerdorf bir betik motoru oluşturmaya karar verdi. Ayrıca formlara da destek verdi ve böylece PHP/F1 biçimlenmiş oldu. Adı duyuldukça kimi geliştiricinin dikkatini çekti ve böylece bir API oluşturuldu: PHP3 meydana geldi. Ardından Zend motoruyla PHP4 geldi. Günümüzde PHP; bloglardan forumlara, portal sistemlerinden veri tabanlarına, sınıflardan fonksiyonlara her türlü işlevde kullanılıyor. Bilindiği gibi bugün “PHP 8.5.12 güvenlik düzeltmeleri ile duyuruldu” başlıklı bir haber yapmış ve bu haberde, önemli güvenlik düzeltmeleri yapıldığını söylemiştik. Aynı durum, PHP 8.3.36 için de geçerli. Bu sürüm, aralarında Core’un da bulunduğu 1 bileşende 1 hata düzeltmesi sunuyor ve dalı üretim kullanımı için güncel tutuyor. Bu bir güvenlik sürümüdür: CVE-2026-109618 ve CVE-2026-109619 açıklarını ele almaktadır. Etkilenen sistemlerin derhal yükseltme yapması öneriliyor. PHP 8.3.36 hakkında bilgi edinmek için sürüm duyurusunu ve değişiklikler sayfasını inceleyebilirsiniz.

Continue Reading →

 

 

 

   PHP 8.3.35 edinmek için aşağıdaki linkten yararlanabilirsiniz.