







IP ağları üzerinde gerçek zamanlı trafik analizi ve paket loglaması yapabilen; yazılım protokol analizi, içerik tarama / eşleme yapabildiği gibi, arabellek taşması, port taraması, CGI saldırısı, işletim sistemi parmakizi denemesi gibi pek çok saldırı ve zararlı / şüpheli yazılım çeşidini tespit edebilen Snort‘un 3.12.4.0 sürümü, GitHub üzerinden, Priyanka Gurudev tarafından duyuruldu. HandshakeComplete olayından ClientHello alanlarının okunduğu belirtilirken, tünel trafiğiyle yapışkan beyaz liste kararının işlenmesinin iyileştirildiği ifade ediliyor. alert_syslog’da meta verilerin saklandığı belirtilirken, cppcheck constParameterPointer uyarısının düzeltildiği söyleniyor. IDS modunda reject ve react’ın düzeltildiği söylenirken, IDS modunda reject için reset eyleminin atlandığı belirtiliyor. TLS null bayt dize işlemesinde bellek sızıntısının düzeltildiği belirtilirken, uyarlanabilir profiller etkinleştirildiğinde TLS şifre çözme atlamasının düzeltildiği söyleniyor. Snort 3.12.4.0 hakkında bilgi edinmek için GitHub sürümler sayfasını incelemek mümkün. Snort; performans, basitlik ve esnekliğe dayalıdır. Ayrıca modüler eklenti mimarisini kullanan tespit motoru da vardır. Gerçek zamanlı alarm mekanizması bulunan Snort; Windows istemcilerine WinPopup pencereleri çıkarabilir, Linux türevlerinde alarm mekanizmalarını syslog’a dahil edebilir ya da özelleştirilmiş günlük dosyasında alarmlarını biriktirebilir.Tim Keary’in hazırladığı Snort Cheat Sheet başlıklı sayfayı incelemenizi öneririm. Yazarın hazırladığı tabloya, aşağıdaki resme tıklayarak da erişebilirsiniz.

Aynı tablonun .pdf formatında olanına ise buradan ulaşabilirsiniz.
Özel istemci ve sunucu tarafı oluşturmak için kullanılabilecek düşük seviye HTTP taşıma bileşenleri seti Apache HttpComponents Core‘nin 5.5-beta4 sürümü duyuruldu. Minimum ayak izi ile istemci ve sunucu tarafı HTTP hizmetleri sunan Apache HttpComponents Core; klasik Java I/O ve engellenmeyen, etkinlik odaklı I/O’ya dayanan I/O modelini engelleme Java NIO’ya dayanan model olmak üzere iki I/O’yu destekliyor. Java NIO’ya dayalı asenkron infaz desteği de dahil olmak üzere HTTP taşıma kütüphanesi içeren yazılım, HTTP için kapsamlı öncelikleme şemasıyla geliyor. Bu BETA sürümün, HTTP/2 protokolü uyumluluğunda birden fazla iyileştirme ve performans optimizasyonu içeridiği, Digest Fields (RFC 9530) desteği sunduğu ve asenkron IO oturum havuzu işlevselliğini geliştirdiği söyleniyor. Bunun, 5.5 GA sürümünden önceki son BETA sürümü olması bekleniyor. Bu sürüm, kararlı 5.4 dalındaki tüm düzeltmeleri içerdiği belirtilirken, bağlantı havuzu uygulamasında iyileştirmeler yapıldığı ifade ediliyor. HTTP mesaj akışı API’leri ve HTTP/2 mesaj akışı zaman aşımı desteği eklendiği belirtilirken, bağlantı başına bekleyen HTTP/2 istek komutları sınırlandırılmış bulunuyor. RFC 7540, HPACK (RFC 7541) ve HTTP/2 (RFC 9113) ile uyumluluk iyileştirilmiş bulunuyor. Apache HttpComponents Core 5.5-beta4 hakkında bilgi edinmek için sürüm duyurusu incelenebilir.
PHP’nin old stable sürümü 8.2.35 duyuruldu. Çeşitli hataları giderilen ve kimi güvenlik düzeltmeleri ve kimi iyileştirmeler içeren yeni sürüm hakkında bilgi edinmek için haberler veya yükseltme sayfalarını inceleyebilirsiniz. PHP, ilk olarak Rasmus Lerdorf tarafından, web üzerinden sayfasını ziyaret edenleri izlemek amacıyla bir dizi Perl betiği kullanılarak geliştirilmişti. Ancak insanlar bununla ilgilenmeye başlayınca, Lerdorf bir betik motoru oluşturmaya karar verdi. Ayrıca formlara da destek verdi ve böylece PHP/F1 biçimlenmiş oldu. Adı duyuldukça kimi geliştiricinin dikkatini çekti ve böylece bir API oluşturuldu: PHP3 meydana geldi. Ardından Zend motoruyla PHP4 geldi. Günümüzde PHP; bloglardan forumlara, portal sistemlerinden veri tabanlarına, sınıflardan fonksiyonlara her türlü işlevde kullanılıyor. Bilindiği gibi bugün “PHP 8.5.12 güvenlik düzeltmeleri ile duyuruldu” başlıklı bir haber yapmış ve bu haberde, önemli güvenlik düzeltmeleri yapıldığını söylemiştik. Aynı durum, PHP 8.2.35 için de geçerli. PHP projesi, 8.2 dalının 1 bileşeninde 1 hata düzeltmesi içeren PHP 8.2.35 sürümünü yayınladı. PHP projesi, 8.2 dalı için bir bakım güncellemesi olan PHP 8.2.35’i yayınladı. Bu sürüm, Core dahil olmak üzere 1 bileşende 1 hata düzeltmesi sunuyor ve dalı üretim kullanımı için güncel tutuyor. Bu bir güvenlik sürümüdür: CVE-2026-109618 ve CVE-2026-109619 açıklarını ele almaktadır. Etkilenen sistemlerin derhal yükseltme yapması öneriliyor. PHP 8.2.35 hakkında bilgi edinmek için sürüm duyurusunu ve değişiklikler sayfasını inceleyebilirsiniz.
PHP’nin old stable sürümü 8.3.36 duyuruldu. Çeşitli hataları giderilen ve çeşitli önemli güvenlik düzeltmeleri ve kimi iyileştirmeler içeren yeni sürüm hakkında bilgi edinmek için haberler veya yükseltme sayfalarını inceleyebilirsiniz. PHP, ilk olarak Rasmus Lerdorf tarafından, web üzerinden sayfasını ziyaret edenleri izlemek amacıyla bir dizi Perl betiği kullanılarak geliştirilmişti. Ancak insanlar bununla ilgilenmeye başlayınca, Lerdorf bir betik motoru oluşturmaya karar verdi. Ayrıca formlara da destek verdi ve böylece PHP/F1 biçimlenmiş oldu. Adı duyuldukça kimi geliştiricinin dikkatini çekti ve böylece bir API oluşturuldu: PHP3 meydana geldi. Ardından Zend motoruyla PHP4 geldi. Günümüzde PHP; bloglardan forumlara, portal sistemlerinden veri tabanlarına, sınıflardan fonksiyonlara her türlü işlevde kullanılıyor. Bilindiği gibi bugün “PHP 8.5.12 güvenlik düzeltmeleri ile duyuruldu” başlıklı bir haber yapmış ve bu haberde, önemli güvenlik düzeltmeleri yapıldığını söylemiştik. Aynı durum, PHP 8.3.36 için de geçerli. Bu sürüm, aralarında Core’un da bulunduğu 1 bileşende 1 hata düzeltmesi sunuyor ve dalı üretim kullanımı için güncel tutuyor. Bu bir güvenlik sürümüdür: CVE-2026-109618 ve CVE-2026-109619 açıklarını ele almaktadır. Etkilenen sistemlerin derhal yükseltme yapması öneriliyor. PHP 8.3.36 hakkında bilgi edinmek için sürüm duyurusunu ve değişiklikler sayfasını inceleyebilirsiniz.
PHP’nin 8.4.27 sürümü duyuruldu. Çeşitli hataları giderilen ve çeşitli önemli güvenlik düzeltmeleri ve kimi iyileştirmeler içeren yeni sürüm hakkında bilgi edinmek için haberler veya yükseltme sayfalarını inceleyebilirsiniz. PHP, ilk olarak Rasmus Lerdorf tarafından, web üzerinden sayfasını ziyaret edenleri izlemek amacıyla bir dizi Perl betiği kullanılarak geliştirilmişti. Ancak insanlar bununla ilgilenmeye başlayınca, Lerdorf bir betik motoru oluşturmaya karar verdi. Ayrıca formlara da destek verdi ve böylece PHP/F1 biçimlenmiş oldu. Adı duyuldukça kimi geliştiricinin dikkatini çekti ve böylece bir API oluşturuldu: PHP3 meydana geldi. Ardından Zend motoruyla PHP4 geldi. Günümüzde PHP; bloglardan forumlara, portal sistemlerinden veri tabanlarına, sınıflardan fonksiyonlara her türlü işlevde kullanılıyor. Bilindiği gibi bugün “PHP 8.5.12 güvenlik düzeltmeleri ile duyuruldu” başlıklı bir haber yapmış ve bu haberde, önemli güvenlik düzeltmeleri yapıldığını söylemiştik. Aynı durum, PHP 8.4.27 için de geçerli. Bu sürüm, Core, BCMath, BZ2, CLI, DOM, FFI gibi 30 bileşende 89 hata düzeltmesi sunuyor ve dalı üretim kullanımı için güncel tutuyor. Bu bir güvenlik sürümüdür: CVE-2026-109618 ve CVE-2026-109619 açıklarını ele almaktadır. Etkilenen sistemlerin derhal yükseltme yapması öneriliyor. PHP 8.4.27 hakkında bilgi edinmek için sürüm duyurusunu ve değişiklikler sayfasını inceleyebilirsiniz.
PHP 8.4.27 edinmek için aşağıdaki linkten yararlanabilirsiniz.
Python programlama dilinin 3.15.1 kararlı sürümü duyuruldu. Python 3.15.1’in, Python programlama dilinin hızlandırılmış bir güvenlik sürümü olduğu belirtilirken, 3.15.0’dan sonra 117 katılımcıdan yaklaşık 330 hata düzeltmesi ve güvenlik iyileştirmesi içeren 3.15.0’ın ilk bakım sürümü olduğu söyleniyor. Bu sürümün, eMudhra / emSign CA sertifikası güvenlik olayını ele almak için sertifika kopyasını 2026.10.19’a yükseltmek için gömülü pipi 26.2.2’ye yükselttiği belirtilirken, daha fazla bilgi için Checkurse‘a bakılabileceği söyleniyor. Windows için sunulan yükleyicinin, Windows Mağazası’ndan veya indirme sayfasından yüklenebilen yeni yükleme yöneticisi tarafından değiştirildiği söyleniyor. Şu anda, gönüllü olarak veya Python Yazılım Vakfı’na kurumsal bağışlarla çabaların desteklenmesinin düşünülmesi rica ediliyor. Python 3.15.1 hakkında bilgi edinmek için sürüm duyurusunu inceleyebilirsiniz.
